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VeNFLoPi Installation Guide 
Flashing Your Raspberry Pi 4B MicroSD Card 

A. Download Raspberry Pi Imager: https://www.raspberrypi.com/software/ 
B. Insert microSD card into your computer, using an adapter if necessary. 
C. Under Device, select Raspberry Pi 4. Then hit next. 
D. Under OS, select Use custom. Then hit next. 
E. Download the .img file of the latest VeNFLoPi release via our GitHub at the following: 

https://github.com/taracdelorme-cloud/VeNFLoPi and select it following step D. 
F. Under Storage, select your microSD (e.g., Generic MassStorageClass Media). Then hit next. 
G. Under Writing, confirm the operating system is VeNFLoPi. Then hit Write.  
H. Select ‘I UNDERSTAND, ERASE AND WRITE’. 
I. MicroSD is finished and automatically ejected. Choose to write another microSD or finish. 

 

  

D

A
https://www.raspberrypi.com/software/

B

MicroSD

Adapter if needed

C

E

Visit our GitHub page for the latest 
release. Download the .img file.

F

G H I
VeNFLoPi

Fig 2. 



 

 3 

Raspberry Pi 4B Configuration 
Layout of onboard interfaces and port mapping 
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Back of Raspberry Pi

Long Short Meaning
0 3 Generic failure to boot
0 4 start*.elf not found
0 7 Kernel image not found
0 8 SDRAM failure
0 9 Insufficient SDRAM
0 10 In HALT state
1 2 SD card overcurrent
2 1 Partition error (not FAT)
2 2 Failed to read from partition
2 3 Extended partition not FAT
2 4 File signature/hash mismatch

Long Short Meaning
3 1 SPI EEPROM error
3 2 SPI EEPROM write protected
3 3 I2C error
3 4 Secure boot config invalid
4 4 Unsupported board type
4 5 Fatal firmware error
4 6 Power failure type A
4 7 Power failure type B
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4 7 Power failure type B 



 

 4 

Camera Module Modification and Integration 
Wide-angle Lens Replacement and Ribbon Cable Assembly 

A. Unscrew and remove IR lights from the main camera mount. 
B. If modifying the camera for a wider field of view, carefully unscrew original lens. 
C. Screw new lens in. There should be no resistance when screwing in the lens! It is sometimes helpful to 

start by applying downward pressure, followed by a slight left-hand turn (counter-clockwise) to set the 
lens and then begin to screw it in by turning the lens to the right (clockwise). Be careful not to over turn 
it at the end as well. 
Note: You can use a graphite pencil to dry lubricate the lens thread, but generally it should go in with 
no resistance if the threading is undamaged. 

D. Adjust focus by gently rotating lens clockwise or counterclockwise until the image is clear. 
E. Attach the ribbon cable end by aligning the connector tabs with the Raspberry Pi port. Lift the black 

locking tab on the Raspberry Pi camera port, insert the ribbon cable fully with the metal contacts facing 
the connector, then press the tab back down to lock it in place. 

F. If all steps are completely correctly you setup should now look like F. 
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IR LED Light Assembly 
Custom IR LED Wiring and Modular Light Assembly 

A. As described by the Glover Lab, the original IR LEDs supplied with the camera can be reused. 
However, they should be removed from the camera assembly and repositioned so the IR lighting is 
separate from the camera lens, allowing improved placement control and more flexible illumination. 
Add heat sinks to the back of each IR LED 

B. Next, four sets of wires need to be crafted: 3 + 4 connects the two IR lights together  
C. 5 + 6 connects the IR lights to the Pi board 
D. IR sensors (1 + 2) connected using wires 3, 4 and 5. 
E. Front view: Ensure all screws are fully tightened. 
F. Connection: Plug Wire 6 into the Raspberry Pi board (details on p. 6) 
G. Note: Premade wires (Item #21) can be used instead of assembling wires manually. If you choose to 

manually make, follow instructions: Strip the wire. To make #3 and #4, attach two ring terminals (item 
#16) to one black and one red wire cut to a short length (item #17) separately via heat shrink tube (item 
#18). To make #5, the wire is left long and one end contains the ring terminal while the other features a 
male two pin housing connector (item #15). The last cable involves taking a red and black wire (item 
#17) cut to medium length and fit one female two pin housing connector (both red and black feed into) 
and then two female one pin housing connectors (one for black and one for red). 
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IR LED Light Case 
3D-Printed IR LED Enclosure and Placement Guidelines 

STL files of the 3D-printed components (designed by the Glover Lab) can be found here: 
https://www.thingiverse.com/gloverlab/designs. We used FDM printer and PETG Filament. 

A. Four individual components make up the case including: 
1. Pi_LED_Base 
2. Pi_LED_Arm_5CM_M2F 
3. Pi_LED_Case_Bottom_w_Mount 
4. Pi_LED_Case_Top 
We opted to use metal nuts and screws including: 
5. #4-40 × 1” screw = 2-4 pieces 
6. #4-40 nut = 2-4 pieces 

B. Be sure to position camera to get good even illumination and everything you want captured in frame. 
Some tips below: 
1. Angle IR LED slightly away from the lens to avoid glare. 
2. Keep LED ~2–5 cm from the camera for even illumination. 
3. Use a diffuser (frosted tape or plastic) to spread light evenly. 
4. Adjust IR intensity or camera exposure to prevent over/underexposure. 
5. Avoid shiny surfaces that can reflect IR back into the lens. 
6. Secure the LED firmly with zip ties, standoffs, or mounts. 
7. Test the setup before filming to check coverage and shadows 

C. We removed the front panel (4) and used zip ties to secure the IR LED, as positioning the front panel 
proved difficult. 
 

  

321 4

Ceiling We opted for zip ties to 
secure IR LED instead.

A

B C

Supplemental Fig 3. 



 

 7 

Camera Arm and Case 
3D-Printed Camera Arm and Protective Case Assembly 

STL files of the 3D-printed components (designed by the Glover Lab) can be found here: 
https://www.thingiverse.com/gloverlab/designs. We used FDM printer and PETG Filament. 

A. Eight individual components make up the arm and case including: 
1. Pi_Cam_Rod_Base 
2. Pi_Cam_Ring_180D 
3. Pi_Cam_Arm_7CM_M2F 
4. Pi_Cam_Arm_7CM_M2F 
5. Pi_Cam_Arm_7CM_M2M_180D 
6. Pi_Cam_Ring_90D 
7. Pi_Cam_Case_Bottom_w_Rod 
8. Pi_Cam_Case_Top 
We opted to use metal nuts and screws instead of 3D-printed versions: 
9. #4-40 × 1” screw = 10 pieces 
10. #4-40 nut = 10 pieces 

     B-D. Front, Side and Back view of camera arm and case. 
     E-F. Top and side view of chamber 
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Attach component to your Raspberry Pi 
Wiring Schematic 

A. Display of the 40-pin GPIO header of the Raspberry Pi 4B with specific pin assignments for external 
components. Wiring connections are assigned as follows: 

B. Custom IR LED lighting: The red (positive) wire is connected to Pin 1 (3.3V Power), and the black 
(negative) wire is connected to Pin 9 (Ground). 

C. Squid Button: One yellow wire is connected to Pin 5 (GPIO 3), and the other is connected to Pin 6 
(Ground). 

D. Cooling fan integrated into the Pi enclosure: The red wire is connected to Pin 4 (5V Power), and the 
black wire is connected to Pin 14 (Ground).  
Note: The blue wire is not utilized in this configuration and should be ignored. 
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Video acquisition 
Configuring Profiles, Resolution, and Recording Paths in OBS 

A. Download OBS for free at https://obsproject.com/download. 
B. Create a profile for your project: Go to Profile → New, enter the profile name. 
C. Click Optimize for Recording Only, click Next. 
D. Set Base Resolution to 1920×1080 and FPS to 60, click Next, and then Apply the settings. 

Note: You can customize base resolution and FPS to meet your needs, but they have to match RPi 
Arducam Settings 

E. Setting Recording Path and Format: Go to File → Settings 
F. Click Output → Advanced, then select the Recording tab. Set the recording path to your computer, an 

external hard drive, or a cloud-based service like OneDrive or Dropbox. Choose MKV as the recording 
format. 

G. Next go to Settings → Advanced, then under Recording, change the file name to include your animal 
ID. Check “Automatically remux to MP4.” 
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Multi-Camera Software Setup 
Creating Scene Collections and Adding Camera Sources in OBS 

A. Go to Scene Collection → New and create a separate collection for each chamber with a camera you 
are recording from. 

B. Select a scene collection, click Add Source 
C. Choose Video Capture Device. 
D. Name the new source, and click OK. 
E. Repeat these steps for all scene collections, opening a new instance of OBS each time.  
F. It will tell you an instance is already running but select Launch Anyway. 
G. Make sure the recording parameters (FPS and Resolution) match between OBS and the RPi device set-

up. 
H. Once done you should have a separate window for each recording. 
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Applying Auto Start-Stop Settings 
Configuring Automated On/Off Recording with Advanced Scene Switcher 

A. Download the Advanced Scene Switcher plugin from the OBS Project website: 
https://obsproject.com/forum/resources/advanced-scene-switcher.395/  

B. After downloading, extract the ZIP file and follow the included instructions to install the plugin into your 
OBS plugins folder. 

C. Restart OBS and navigate to Tools → Advanced Scene Switcher  
D. → Macro. Click the + button to create a new macro, provide a name, and click OK.  
E. Select the macro, add a Condition: If → Recording → Recording Running. 

Then add the following Actions in sequence: Wait → Fixed → 1 hour (or any desired interval), 
Recording → Stop, Wait → Fixed → same interval, Recording → Start. To activate the macro, ensure 
the checkbox is selected; to deactivate it, clear the checkbox. 
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Applying Shader Settings 
Applying Fisheye Correction Using the OBS ShaderFilter Plugin 

A. Install OBS ShaderFilter plugin: Go to its GitHub page https://github.com/Oncorporation/obs-
shaderfilter.  

B. Navigate to Releases → Assets. 
C. You should see a file like obs-shaderfilter-win.zip. Download and extract this ZIP file.  
D. Inside the extracted folder, locate the data and obs-plugins folders, and move both into your OBS 

Studio installation directory on your desktop, replacing or merging with any existing folders as needed. 
E. Install Fisheye shader. 
F. Navigate to data → examples in the extracted ShaderFilter folder and locate the file fisheye.shader. 
G. Move or copy this file into your OBS installation at Desktop → obs-studio → data → obs-plugins → 

obs-shaderfilter → examples.  
H. Then, open OBS go to Sources and click Filters.  
I. Choose User Defined Shader and give it a name.  
J. Click Load Shader Text From File to select your shader to apply ShaderFilter to your desired source.  
K. Click its name to adjust the Power setting to achieve the desired effect. 
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Video Stitching 
Installing Python and Miniconda for Video Stitching 

A. Setting up Python via Anaconda. Navigate to https://www.anaconda.com/download. 
B. Scroll down and click “Download Miniconda installer.” 
C. Select the appropriate operating system and installer (e.g., Windows 64-bit graphical installer). 

Download the installer and launch the executable once the download is complete. 
Follow the installation prompts using default settings. 
 
Verify successful installation by opening Anaconda Prompt and running: 

conda -version # Confirms Anaconda is correctly installed 
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FFmpeg Installation for Video Processing 
Installing and Configuring FFmpeg on Windows for Video Processing 

A. Download the FFmpeg ZIP file from https://www.ffmpeg.org/download.html. 
Hover over the Windows icon, select Windows builds from gyan.dev under Windows EXE Files, then 
download the ZIP file under Release builds (e.g., ffmpeg-release-essentials.zip). 

B. Extract the ZIP file by right-clicking and selecting Extract All 
C. Select a location of your choice for the information to reside 
D. Confirm the extracted bin folder contains ffmpeg.exe 
E. Go to Settings → System → About → Advanced system settings to open System Properties 
F. Now via System Properties go to Advanced → Environment Variables 
G. In Environment Variables under System variables choose Path → Edit 
H. Add FFmpeg to the system PATH: Select New and then paste the path to the bin directory from before 

and click OK to save 
 
I. Verify installation in Anaconda Prompt by running: 

ffmpeg -version  # Version information confirms successful setup  
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Stitch video files 
Stitching Short Video Segments into Continuous Files Using FFmpeg and Python 

A. Download stitch_videos.py from our GitHub at the following: https://github.com/taracdelorme-
cloud/VeNFLoPi and save it to your desktop. A quick copy-able version is also provided below.  

B. Open stitch_videos.py in any text editor and update parent_dir to the folder path where your videos are 
located. 

C. Open the Anaconda Prompt and run the following: 

conda install -c conda-forge opencv # Install OpenCV dependency 

cd C:\Users\loganlab\Desktop # Navigate to script location [use your path] 

D. Run script: 

python stitch_videos.py 

E. For each subfolder, a stitched grayscale video is saved as <subfolder_name>_stitched.mp4, showing 

sequential frames with vertical timestamps along the bottom-left and skipping near-black frames for 

clarity. 

That’s it! 

All you should need to stitch interval recorded videos 


